Archive for August 2012

Windows 8 Eingabe des Produktschlüssels bei der Installation umgehen

30 August 2012

Bei Windows 7 war es problemlos möglich eine Version zu installieren, um mal schnell etwas auszutesten, denn man konnte bei der Installation die Eingabe des Produktschlüssels übergehen. Dies wurde bei Windows 8 leider geändert.

Aber man kann durch einen kleinen Trick die Eingabe des Produktschlüssels wieder auf später verschieben. Dazu muss nur die Datei EI.CFG im SOURCES-Verzeichnis mit folgendem Inhalt angelegt werden:

[Channel]
Retail

Das wars. Bei der Installation wird man nicht mehr belästigt und nach dem ersten Neustart kann man die Eingabe des Schlüssels übergehen.

Für USB-Sticks eine leichte Aufgabe, bei Verwendung von ISOs oder DVDs müssen natürlich die Medien dazu neu erstellt werden.

Weitere Infos über die EI.CFG hier: https://newyear2006.wordpress.com/2009/12/13/windows-7-versionsauswahl-bei-installation/

Neue GHOST-Version in Form von GSS Version 3 im Anmarsch?

29 August 2012

Seit Jahren hat sich in Sachen GHOST von Symantec nichts getan. Aber es ist einfach ein hilfreiches Tool, welches selbst noch aktuell mit Windows 8 und Server 2012 hilfreiche Dienste leisten kann.

Da sich seit Jahren nichts mehr getan hat, bin ich seit einiger Zeit auf der Suche nach Alternativen, wie z. B. hier https://newyear2006.wordpress.com/2012/07/02/ghost32-exe-ersatz-mittels-windows-8-bzw-winpe-4-oder-wie-erstelle-ich-ein-festplattenimage-mit-windows-bordmitteln/ oder hier https://newyear2006.wordpress.com/2010/11/21/ghost-enterprise-ersatz/ und hier https://newyear2006.wordpress.com/2007/02/09/festplatten-clonen-mit-windows-vista-dvd-und-robocopy/.

Aktuelle Entwicklungen wie UEFI-Boot, native 4K-Sektoren, VHD und VHDX machen den Umgang mit Ghost immer schwieriger.

Nun hat sich aber in einem Symantec-Forum etwas erstaunliches abgespielt, hier der Auszug von jon_sharp:

Hello everyone. I just wanted to introduce myself as the new Product Manager for GSS, so you know where I’m coming from.

While Nigel is correct that it has been some time since we’ve released a new version of GSS. I want to assure you, though, that we have a release planned for next year. There is no plan to replace GSS with Deployment Solution. Though that might have been the plan at some point, it isn’t the plan as of today. I apologize to the community at large that this information hasn’t been shared before now.

I know GSS has gone through a rocky past couple of years, but we (Symantec) believe there’s tremendous value in continuing work on GSS. Please take this as the official word from Symantec, because that’s what it is. 🙂

Thanks,
Jon

http://www.symantec.com/connect/forums/ghost-solution-suite-or-wds

Es gibt zwar Verzögerungen aber anscheinend wird an einer neuen Version gearbeitet. Also mal schauen wie sich die Sache entwickelt.

Probleme mit Windows Vista nach Umzug auf eine neue Festplatte mit 512e und Sektorgröße von 4K und Windows Update 0xC8000222 Fehler sowie EDB.LOG

26 August 2012

Auf einem Windows Vista SP2 System musste die Festplatte ausgetauscht werden. Dabei wurde mittels Ghost32 die Festplatte auf die neue Festplatte kopiert.

Leider funktionierte danach die Windowsupdatefunktion nicht mehr und es wurden ESENT Fehlermeldungen in der Anwendungslog aufgezeichnet:

Log Name: Application 
Source: ESENT 
Date: <date & time>
Event ID: 412 
Task Category: Logging/Recovery 
Level: Error 
Keywords: Classic 
User: N/A 
Computer: <computer name> 
Description: 
wuaueng.dll (936) SUS20ClientDataStore: Unable to read the header of logfile C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log. Error -546.

Wenn man versuchte Windowsupdate versuchte aufzurufen bekam man die Fehlermeldung:

FATAL: Failed to initialize datastore, error = 0xC8000222.

Na prima. Die Problematik mit passendem Hotfix ist hier dokumentiert: http://support.microsoft.com/kb/2470478.

Doof an der Sache ist aber, wenn man versucht den Hotfix zu installieren, dann erhält man postwendend wieder den Fehler 0xC8000222! Was soll das?

Die Lösung brachte dann das Löschen der C:\Windows\SoftwareDistribution\DataStore\Logs\edb.log Datei! Danach konnte der Hotfix eingespielt werden sowie Windows Updates eingespielt werden.

Eine spätere Recherche brachte dann über diesen Artikel http://support.microsoft.com/kb/2510009 dann speziell für die Vista Variante noch diesen Hotfix ins Spiel: http://support.microsoft.com/kb/2553708. Dieser erlaubt mehr Infos auch in Windows Vista über fsutil zu erhalten.

Bei Verwendung des Remote Desktop unter Windows erscheint ständig eine Zertifikatswarnmeldung obwohl man bereits das Zertifikat installiert hat

26 August 2012

Wenn man mit den Standardeinstellungen eine Verbindung zum Remotedesktop eines anderen Windows-Rechners aufbaut der nicht in derselben Domäne sitzt, wird man mit Warnhinweisen traktiert. An sich ist die Sache ja gut, nur leider führt die Art wie die Dialoge reagieren zu dem Ergebnis, dass die Anwender genervt sind und im Zweifel ihre Sicherheitseinstellungen reduzieren um zum Ziel zu kommen.

Hier sind die Masken (noch Win7) schön dargestellt und die Situation gut beschrieben: http://serverfault.com/questions/7653/remote-desktop-keeps-asking-me-to-accept-a-certificate

Blöd an der Sache ist, dass selbst wenn man sagt, man möchte das Zertifikat installiert bekommen, dass es dann beim nächsten Aufruf wieder nicht klappt. Das verwirrt und sorgt für die Konditionierung, dass einfach immer alles weggeklickt wird, Hauptsache es funktioniert irgendwie. Aber das kann es nicht sein!

Was passiert hier effektiv? Wenn man die Installation des Zertifikats dem System überlässt, wird das Zertifikat beim aktuellen Benutzer abgespeichert und zwar unter den Zwischenzertifizierungsstellen. Damit das Zertifikat seiner Bedeutung gerecht werden kann, muss es aber im Computerkonto unter Vertrauenswürdige Stammzertifizierungsstellen enthalten sein. Warum das so ist? Keine Ahnung, aber ich spekuliere mal darauf, dass auch bestimmte Dienste (Netzwerk) zur Absicherung der Verbindung benutzt werden und diesen das Zertifikat vom Benutzer nicht zur Verfügung steht.

Lösung unter Windows 8 und Server 2012
Windows 8 und Windows Server 2012 bringen eine Verbesserung der Situation. War seither beim Importassistent immer nur die Installation des Zertifikats beim aktuellen Benutzer möglich, erscheint nun nach Auswahl von “Zertifikat installieren” zuallererst die Rückfrage nach dem Speichertort, wo man zwischen “Aktueller Benutzer” und “Lokaler Computer” wählen kann. Leider ist aber der Rest des Assistenten genauso unübersichtlich wie früher. D. h. am Ende des Importvorgangs ist nicht klar wo das Zertifikat gelandet ist!

Denn das dumme daran ist, dass das Zertifikat nicht im Speicher der Vertrauenswürdigen Stammzertifizierungsstellen gespeichert wird, auch wenn man den lokalen Computer zuerst ausgewählt hat. Wie vor Windows 8 wird es, bei Verwendung der Vorgabe den Zertifikatsspeicher automatisch zu wählen, im Speicher der Zwischenzertifizierungsstellen gespeichert! Ob Bug oder Feature kommt noch hinzu, dass das Zertifikat nicht nur beim lokalen Computer landet sondern auch noch beim aktuellen Benutzer. Beim Testen wurde bereits Windows 8 RTM verwendet!

Das Zertifikat wird also nur sauber gespeichert wenn man “Lokalen Computer”, “Alle Zertifikate in folgendem Speicher speichern” und als Speicherort “Vertrauenswürdige Stammzertifizierungsstellen” auswählt.

Lösung für Windows 7, Server 2008 R2 und davor
Man kann nun mittels MMC und dem Zertifikats-Snapin einmal das Computerkonto und den Zertifikatsspeicher des aktuellen Benutzer öffnen und dann das betreffende Zertifikat vom einen Speicher in den anderen verschieben. Lästig aber ist so.

Leerer Bildschirm beim Outlook Web Access nach Exchange Server 2010 Update in Verbindung mit KB2743248

17 August 2012

Ja schon oft gelesen und gesehen und nun selber erwischt. Beim Aufruf der OWA Anmeldeseite eines Exchange Servers passierte nicht viel, es wird nur ein leerer Bildschirm angezeigt. Man kann, welchen Browser auch immer nehmen, es funktioniert nicht. Auch direkt auf dem Server per http://localhost/OWA geht nix.

Die URL welche normalerweise dabei zu sehen ist, gleicht dieser:

https://server.domain.com/owa/auth//logon.aspx?url=https://server.domain.com/owa/&reason=0

Und jetzt?

Z. B. OWA-Troubleshooting, indem man prüft, ob auch das RPC over HTTP Feature aktiv ist: http://www.techhelpblog.com/2011/04/01/how-to-fix-exchange-2010-blank-owa-screen-install/. Es gibt im Netz massig viele andere Möglichkeiten, unter anderem auch sowas: http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/1d8fa60f-aac1-497a-9b64-2cac524b0b63/, hier hatte jemand Adobe Cold Fusion  auf dem Exchange Server installiert!

Die Möglichkeiten sind mannigfaltig. Im konkreten Fall war zuerst Mal wichtig zu prüfen, welche Version zum Einsatz kommt, denn es waren just kurz davor Windows Updates auf dem Server eingespielt worden. Die einfachste Variante ist vom leeren Browserfenster sich den Sourcecode der HTML-Seite anzeigen zu lassen.

Obwohl am Bildschirm nichts zu sehen ist, enthält der HTML-Code eine interessante Info: Es ist ein Link auf ein PNG-Bild enthalten, welcher

/owa/14.1.420.0/themes/base/warn.png

lautet.

Durch diesen Anhaltspunkt kann man unter http://social.technet.microsoft.com/wiki/contents/articles/240.exchange-server-and-update-rollups-build-numbers-en-us.aspx nachschauen um herauszufinden, mit welcher Version man es zu tun hat:

Exchange Server 2010 Service Pack 1

Product name Build number Date KB
Microsoft Exchange Server 2010 SP1 14.1.218.15 8/24/2010  
Update Rollup 1 for Exchange Server 2010 SP1 14.1.255.2 10/4/2010 KB2407028 
Update Rollup 2 for Exchange Server 2010 SP1 14.1.270.1 12/9/2010 KB2425179 

 Update Rollup 3 for Exchange Server 2010 SP1

14.1.289.3 3/7/2011 KB2492690 
Update Rollup 3-v3 for Exchange Server 2010 SP1 14.1.289.7 4/1/2011 KB2529939 
Update Rollup 4 for Exchange Server 2010 SP1 14.1.323.1 6/22/2011  KB2509910 
Update Rollup 4-v2 for Exchange Server 2010 SP1 14.1.323.6 7/27/2011 KB2579150 
Update Rollup 5 for Exchange Server 2010 SP1 14.1.339.1 8/23/2011  KB2582113 
Update Rollup 6 for Exchange Server 2010 SP1 14.1.355.2 10/27/2011  KB2608646 
Update Rollup 7 for Exchange Server 2010 SP1 14.1.421.0   8/13/2012  KB2743248  


Aha! Hier findet sich die Version 14.1.421.0 wieder und das vor vier Tagen, also muss es das letzte Update mitausgelöst haben. Unter KB2743248 ist dann auch die Rede davon, dass man das Update über die normalen Wege deinstallieren kann.

Klar reißt man erst Mal eine Riesenlücke auf, da es ja einen Grund für das Update gab, aber die OWA-Benutzer sind erst Mal glücklich, denn nach der Updateentfernung lief OWA wieder ganz normal.

Jetzt kann man sich in Ruhe an das eigentliche Problem machen.

Fehlermeldungen bei Installation von Programmen die das .Net Framework 3.5 unter Windows 8 oder Windows Server 2012 benötigen

16 August 2012

Wenn es Probleme bei der Installation einer Anwendung gibt, die dass .Net Framework 3.5 benötigt, so könnten aktuell drei verschiedene Fehlernummern auftauchen. In allen drei Fällen gibt es unterschiedliche Gründe warum es nicht klappt. Sei es der Download funktioniert nicht oder die Dateien sind im hinterlegten Pfad nicht zu finden.

0x800F0906 – CBS_E_DOWNLOAD_FAILURE

0x800F081F – CBS_E_SOURCE_MISSING

0x800F0907 – CBS_E_GROUPPOLICY_DISALLOWED

Wie man das Problem löst und wie man am besten vorgeht, beschreibt dieser Artikel: http://support.microsoft.com/kb/2734782/en-us

Weitere Infos hält auch dieser Artikel parat: http://msdn.microsoft.com/library/windows/hardware/hh975396