Sharepoint PreUpgradeCheck meldet fehlenden Web Part aber in welcher Site?


Wenn man bei einer Sharepoint-Migration vorneweg den PreUpgradeCheck mittels

C:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\12\BIN>stsadm -o preupgradecheck

den Prüflauf startet, kann es passieren, dass bei ServerConfigErrors Fehlgeschlagen gemeldet wird:

Processing configuration file: WssPreUpgradeCheck.xml
        OSPrerequisite… Fehlgeschlagen
        WindowsInternalDatabaseMigration… Bestanden
        WindowsInternalDatabaseSite… Bestanden
        MissingWebConfig… Bestanden
        ReadOnlyDatabase… Bestanden
        InvalidDatabaseSchema… Bestanden
        ContentOrphan… Bestanden
        SiteOrphan… Bestanden
        ServerConfigErrors… Fehlgeschlagen
        FormsAuthenticationApplications… Bestanden
        PendingUpgrade… Bestanden
        InvalidServiceAccount… Bestanden
        InvalidHostName… Bestanden
        UnsupportedSqlServerVersion… Bestanden
        ServerInfo… Nur zu Informationszwecken
        FarmInfo… Nur zu Informationszwecken
        SiteDefinitionInfo… Nur zu Informationszwecken
        LanguagePackInfo… Nur zu Informationszwecken
        FeatureInfo… Nur zu Informationszwecken
        EventReceiverInfo… Nur zu Informationszwecken
        WebPartInfo… Nur zu Informationszwecken
        AamUrls… Nur zu Informationszwecken
        LargeList… Bestanden
        CustomListViewInfo… Bestanden
        CustomFieldTypeInfo… Bestanden
        CustomWorkflowActionsFileInfo… Bestanden
        ModifiedWebConfigWorkflowAuthorizedTypesInfo… Nur zu Informationszweck
en
        ModifiedWorkflowActionsFileInfo… Bestanden
        DisabledWorkFlowsInfo… Bestanden
        SPSearchInfo… Nur zu Informationszwecken

Operation completed successfully.

Please review the results at C:\Programme\Gemeinsame Dateien\Microsoft Shared\We
b Server Extensions\12\Logs\PreUpgradeCheck-20130426-080529-978.htm.

In der genannten HTML-Datei findet man dann nur den Hinweis:

Issue : Missing server file or server configuration issues

Server side files are referenced in the content databases, but are not installed on the server. Without these files, the sites may not function completely or the content may not render correctly. Also, upgrade or post upgrade issues may occur if these files are not available in the new version environment.The following web part(s) are referenced by the content, but they are not installed on the web server

Id = e0c4048d-32c1-444d-d672-c86c215757bc, Type = Unknown, Reference = 1, Status = Missing

For more information about this rule, see KB article 976218 in the rule article list at http://go.microsoft.com/fwlink/?LinkID=120257.

Wenn man dann im Dokument, in diesem Fall nach

e0c4048d-32c1-444d-d672-c86c215757bc

sucht, kommt z. B. dies zum Vorschein:

Information Only : Web Part information

The following web parts are being used in this SharePoint farm:

Id = ce9aa113-48cf-ddee-0c03-597445e5b7ab, Type = Microsoft.SharePoint.WebPartPages.ImageWebPart, Reference = 7, Status = Installed
Id = 293e8d0e-486f-e21e-40e3-75bfb77202de, Type = Microsoft.SharePoint.WebPartPages.ListFormWebPart, Reference = 431, Status = Installed
Id = 2242cce6-491a-657a-c8ee-b10a2a993eda, Type = Microsoft.SharePoint.WebPartPages.ListViewWebPart, Reference = 556, Status = Installed
Id = 99cdf365-0cee-2fb2-c12b-ce285a898031, Type = Microsoft.SharePoint.WebPartPages.BlogAdminWebPart, Reference = 2, Status = Installed
Id = e60f6c95-e86c-4717-2c0d-6d8563c9caf7, Type = Microsoft.SharePoint.WebPartPages.ContentEditorWebPart, Reference = 10, Status = Installed
Id = b9a7f972-708a-cd77-4ffd-a235dfed5c38, Type = Microsoft.SharePoint.WebPartPages.DataFormWebPart, Reference = 44, Status = Installed
Id = 404822d6-cc74-7e5c-6767-b8206c1490fc, Type = Microsoft.SharePoint.WebPartPages.SimpleFormWebPart, Reference = 3, Status = Installed
Id = e0c4048d-32c1-444d-d672-c86c215757bc, Type = Unknown, Reference = 1, Status = Missing
Id = 08f1dc7f-a471-2beb-1e5b-00ea35abba18, Type = Microsoft.SharePoint.WebControls.TopologyViewWebPart, Reference = 1, Status = Installed

For more information about this rule, see KB article 976217 in the rule article list at http://go.microsoft.com/fwlink/?LinkID=120257.

Wie immer wird auf den “Alles und Nichts” sagenden Artikel 976217 in der Knowledge Base verwiesen.

Wenn eine GUID angeprangert wird, so hilft ein schneller Check mit Google, ob die betreffende GUID irgendwo schon mal aufgetaucht ist.

Um nun aber die Site zu ermitteln, um eine Ahnung zu haben, um was es gehen könnte, verwendet man diesen Befehl:

C:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\12\BIN>stsadm -o enumallwebs -includewebparts > WebParts.txt

Sucht man nun in der erstellten WebParts.txt, tritt folgendes zu Tage:

  <Database SiteCount="2" Name="WSS_Content" DataSource="SERVER\Microsoft##SSEE">
    <Site Id="cb78e18b-552b-4baf-85a1-451034c87581" OwnerLogin="DOMÄNE\Benutzer" InSiteMap="True">
      <Webs Count="10">
        <Web Id="f0122e69-dd11-415a-887e-a229f4c705b9" Url="/sites/test" LanguageId="1031" TemplateName="STS#1" TemplateId="1">
          <WebParts>
            <WebPart Id="ce9aa113-48cf-ddee-0c03-597445e5b7ab" Count="1" Status="Installed" Type="Microsoft.SharePoint.WebPartPages.ImageWebPart" />
            <WebPart Id="293e8d0e-486f-e21e-40e3-75bfb77202de" Count="30" Status="Installed" Type="Microsoft.SharePoint.WebPartPages.ListFormWebPart" />
            <WebPart Id="2242cce6-491a-657a-c8ee-b10a2a993eda" Count="30" Status="Installed" Type="Microsoft.SharePoint.WebPartPages.ListViewWebPart" />
            <WebPart Id="e0c4048d-32c1-444d-d672-c86c215757bc" Count="1" Status="Missing" />
          </WebParts>
        </Web>

Die schon bekannte Info. Da es sich aber um eine XML-Datei handelt, die hierarchisch aufgebaut ist, kommt man nun an die Site, wo der Part verwendet wird, hier also “/sites/test”. Hiermit dürfte alles klar sein, im Einzelfall muss man nun halt abklären, wer für den Part bzw. die Site zuständig ist.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s


%d Bloggern gefällt das: